扩大
缩小

HDUOJ1021 Fibonacci Again

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21187    Accepted Submission(s): 10145


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

 

Sample Input
0 1 2 3 4 5
 

 

Sample Output
no no yes no no no
 
#include <stdio.h>
#define maxn 1000010
int str[maxn];
int main()
{int i,x;
    str[0]=1;str[1]=2;
    for(i=2;i<maxn;i++)
        str[i]=(str[i-1]+str[i-2])%3;
    while(scanf("%d",&x)!=EOF)
    {
        
    printf("%s\n",str[x]%3==0?"yes":"no");
    }
    return 0;

 

posted on 2012-07-27 22:48  LinuxPanda  阅读(199)  评论(0编辑  收藏  举报

导航