PAT Advanced 1046 Shortest Distance(20)

题目描述:

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10^5]), followed by N integer distances D1 ​D2 ​⋯ DN​, where Di​ is the distance between the i-th and the (i+1)-st exits, and DN​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10^4), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^7.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

算法描述:前缀和

题目大意:

铁路有很多路口(呈环状),分别给出n个 某路口到相邻路口的路径 和 m次查询
路径 i 表示路口 i 到路口 i+1 的距离,每次查询给出两个路口,每次查询求最短距离
只能顺时针或逆时针走

#include<iostream>
#include<algorithm>
using namespace std;

const int N = 100010;
int n, m;
int a[N], s[N];

int main()
{
    cin >> n;
    for(int i = 1 ; i <= n ; i ++)  
    {
        scanf("%d", &a[i]);
        s[i] = s[i - 1] + a[i];
    }
    
    cin >> m;
    while (m --)
    {
        int l, r;
        scanf("%d %d", &l, &r);
        int x = abs(s[r - 1] - s[l - 1]);

        printf("%d\n", min(x, s[n] - x) );
    }
    return 0;
}
posted @ 2022-08-12 16:45  D_coding_blog  阅读(19)  评论(0编辑  收藏  举报