PAT Advanced 1011 World Cup Betting(20)

题目大意:

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

算法描述:模拟 比较排序

题目大意:

分别给出3个游戏 胜 平 输 三个事件的倍率,输出收益最大的下注方法和最大收益(公式已给出)

#include<iostream>
using namespace std;

const int N = 100010;
char s[3] = {'W','T','L'};

int main()
{
    double cmp[3] ,b[3];
    int a[3];
    for(int i = 0 ; i < 3 ; i++)
    {
        double max = -1;
        for(int j = 0 ; j < 3 ; j++){
            cin >> cmp[j];
            if( max < cmp[j] )
            {
                max = cmp[j];
                a[i] = j;
                b[i] = max;
            }
        }
    }
    printf("%c %c %c %.2f",s[a[0]],s[a[1]],s[a[2]],(b[0]*b[1]*b[2]*0.65-1)*2);
    return 0;
}
posted @ 2022-08-12 16:33  D_coding_blog  阅读(14)  评论(0编辑  收藏  举报