PAT Advanced 1002 A+B for Polynomials(25)

题目描述:

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K  N1​ aN1​ ​  N2​ aN2​ ​ ...  NK​ aNK​ ​

where K is the number of nonzero terms in the polynomial,

 Ni​ and aNi​ ​(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK​<⋯<N2​<N1​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

算法描述:多项式加法 模拟

题目大意:

给出两个数的多项式项数和每一项系数,输出多项式相加后的项数和个系数

#include<iostream>
#include<map>
#include<cstdio>
using namespace std;

int main()
{
    map<int, double> xs;
    int n;
    cin >> n;
    while(n --)
    {
        int x;
        double y;
        cin >> x >> y;
        xs[x] += y;
    }
    
    cin >> n;
    while(n --)
    {
        int x;
        double y;
        cin >> x >> y;
        xs[x] += y;
        if(xs[x] == 0)  xs.erase(x);
    }
    
    cout << xs.size();
    // map容器只能用迭代器方式遍历   size - 1 遍历到 0 
    for(auto i = xs.end() ; i != xs.begin() ;)
    {
        i --;
        printf(" %d %.1lf", i->first, i->second);
    }
        
    return 0;
}
posted @ 2022-08-12 15:57  D_coding_blog  阅读(26)  评论(0编辑  收藏  举报