HDU-1001Sum Problem

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 
Input
The input will consist of a series of integers n, one integer per line.
 
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 
Sample Input
1 100
 
Sample Output
1 5050
 
ac代码:
#include<stdio.h>
main()
{
signed __int64 n,sum=0,i;
    while
(scanf("%I64d",&n)!=EOF)
    {

        for
(i=1;i<=n;i++)
        {

            sum+=i;
        }

        printf("%I64d\n\n",sum);
        sum=0;
    }
}
posted @ 2013-04-14 16:09  xiaxiaosheng  阅读(116)  评论(0编辑  收藏  举报