HDU Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 191 Accepted Submission(s): 98
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 
Sample Output
Case 1:
14 1 4

Case 2:
7 1 6
#include <iostream>
using namespace
std;
int
main()
{

    int
T,N,max,sum,start,end,temp,t;

    cin>>T;
    int
h = T;
    while
(T--)
    {

        sum = 0;
        start = 1;
        end = 1;
        temp = 1;
        max = -1001;
        cin>>N;
       for
(int i = 1; i <= N; i++)
       {

            cin>>t;
            sum +=t;
            if
(sum>max)
            {

                max = sum;
                end = i;
                start = temp;
            }

            if
(sum<0)
            {

                sum = 0;
                temp = i+1;
            }
       }

       if
(T!=0)

       cout<<"Case "<<h-T<<":"<<endl<<max<<" "
       <<
start<<" "<<end<<endl<<endl;
       else
cout<<"Case "<<h-T<<":"<<endl<<max
       <<
" "<<start<<" "<<end<<endl;
    }

    return
0;
}

posted on 2011-08-03 09:59  NewPanderKing  阅读(385)  评论(0编辑  收藏  举报

导航