Lucky Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1240    Accepted Submission(s): 635

Problem Description

To Chinese people, 8 is a lucky number. Now your task is to judge if a number is lucky.
We say a number is lucky if it’s a multiple of 8, or the sum of digits that make up the number is a multiple of 8, or the sum of every digit’s square is a multiple of 8.

Input

The first line contains an integer stands for the number of test cases.
Each test case contains an integer n (n >= 0).

Output

For each case, output “Lucky number!” if the number is lucky, otherwise output “What a pity!”.

Sample Input

2

0

8

Sample Output

Lucky number!

Lucky number!

Author

dandelion

Source

HDU2010省赛集训队选拔赛(校内赛)

Recommend

lcy

 解题报告:简单题,就是判断一个数、每位数的和或者每位数平方的和能被8整除,就是一个Lucky number!

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
int n, t, sum1, flag, sum2;
scanf("%d", &t);
while (t --)
{
flag = 0;
scanf("%d", &n);
if (n == 0 || n % 8 == 0)
{
flag = 1;
}
else
{
sum1 = 0;
sum2 = 0;
while (n)
{
sum1 += n % 10;
sum2 += (n % 10) * (n % 10);
n = n / 10;
}
}
if (sum1 % 8 == 0 || sum2 % 8 == 0)
{
flag = 1;
}
if (flag)
{
printf("Lucky number!\n");
}
else
{
printf("What a pity!\n");
}
}
return 0;
}



posted on 2012-04-01 23:46  Stephen Li  阅读(557)  评论(0编辑  收藏  举报