Parencodings

Time Limit: 1000MS

 

Memory Limit: 10000K

Total Submissions: 13696

 

Accepted: 8145

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 


        S              (((()()())))


        P-sequence         4 5 6666


        W-sequence         1 1 1456

 


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2

6

4 5 6 6 6 6

9

4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6

1 1 2 4 5 1 1 3 9

Source

Tehran 2001

 解题报告:这道题的题意就是给我们P序列,让我们求S序列,P-sequence表示第i个‘)’之前有几个‘(’,而S-sequence是表示在第i个“)”和它相匹配的(号中有几对相匹配的“()”的个数,包括它本身;现根据P序列求出括号的排列顺序,再求出S序列即可,主要就是找规律!

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
const int N = 50;
int pse[N], wse[N], fuhao[N];
int visit[N];
int main()
{
int t, n, i, j, k;
scanf("%d", &t);
while (t --)
{
memset(pse, 0, sizeof(pse));
memset(wse, 0, sizeof(wse));
memset(fuhao, 0, sizeof(fuhao));
memset(visit, 0, sizeof(visit));
scanf("%d", &n);
for (i = 1; i <= n; ++i)
{
scanf("%d", &pse[i]);
}
int count;
for (i = 1, count = 1; i <= n; ++i)
{
int num = pse[i] - pse[i -1];//两个相邻的有括号中间的左括号的个数
while (num --)
{
fuhao[count ++] = 0;//符号为左括号时
}
fuhao[count ++] = 1;
}
k = 1;
for (i = 1; i <= 2 * n; ++i)
{
if (fuhao[i])
{
count = 1;
for (j = i - 1; j >= 1; -- j)
{
if (visit[j]==0 && !fuhao[j])//找到与之相匹配的(的位置
{
visit[j] = 1;
break;
}
else if (visit[j] && !fuhao[j])//求中间的左括号(的个数
{
count ++;
}
}
wse[k ++] = count;
}
}
for (i = 1; i < k - 1; ++i)
{
printf("%d ", wse[i]);
}
printf("%d\n", wse[i]);
}
return 0;
}



posted on 2012-02-27 20:20  Stephen Li  阅读(188)  评论(0编辑  收藏  举报