find the nth digit

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4512    Accepted Submission(s): 1256

Problem Description

假设:
S1 = 1
S2 = 12
S3 = 123
S4 = 1234
.........
S9 = 123456789
S10 = 1234567891
S11 = 12345678912
............
S18 = 123456789123456789
..................
现在我们把所有的串连接起来
S = 1121231234.......123456789123456789112345678912.........
那么你能告诉我在S串中的第N个数字是多少吗?

Input

输入首先是一个数字K,代表有K次询问。
接下来的K行每行有一个整数N(1 <= N < 2^31)。

Output

对于每个N,输出S中第N个对应的数字.

Sample Input

6

1

2

3

4

5

10

Sample Output

1

1

2

1

2

4

Author

8600

Source

HDU 2007-Spring Programming Contest - Warm Up (1)

Recommend

8600

代码如下:

#include <iostream>

#include <cstdio>

#include <cstring>

#include <cstdlib>

using namespace std;

int main()

{

int n,i,t,m;

scanf("%d",&t);

while(t--)

{

scanf("%d",&n);

i=1;

m=n;

while(m>i)//m求的是n最终落在Sm区间上,且Sm有m个数

{

m=m-i;//因为每次都增加i个数,

i++;

}

m=m%9;//因为循环节为九

if(m==0)

{

printf("9\n");

}

else

{

printf("%d\n",m);

}

}

return 0;

}



posted on 2011-12-03 16:52  Stephen Li  阅读(374)  评论(0编辑  收藏  举报