HDU1541--Stars(树状数组)

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8610    Accepted Submission(s): 3428


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
1 2 1 1 0
 
题目大意:
题目的意思是说在二维平面直角系上画出一些星星,求每个等级的星星有多少个。对于等级的概念是这样的:在这个星星左下方的星星个数(当然包括自身下方的星星)。题目样例中给出星星的个数n和横纵坐标,输出等级从0~n-1。

解题思路:
刚开始的时候不怎么有思路,直接暴力接触,开一个x[]的数组保存每个点的横坐标,开一个y[]的数组保存每一个点的纵坐标。用双重for循环去跑,直接统计左下方星星的个数,然后对应的等级上面++。投了很多次,侥幸AC。然后看了网上的题解,明白是用树状数组过。首先我们可以假设存在一个数组a[]。它是用来保存当前x坐标为i的星星的个数的a[i]。为什么要这么做?因为我们观察数据输入可以知道,输入是有规律的,先按照y坐标不变,x坐标依次增大的顺序,然后y坐标变大,再按照x坐标依次增大的顺序来输入。假如,y坐标不变,每次输入进来一个坐标,只要看x就可以了,y可以忽略。每次进来一个星星,就a[i]++,同时计算这个星星的等级,level=a[0]+a[i]+a[2]+...a[i]。看着很像树状数组里面的区间求和啊。那么y增大会不会有影响呢?答案是不会的,因为y增大后新进来的星星肯定在原来星星的上方,相当于直接对a[]数组更新,有点滚动数组的味道,然后求得是左下方星星的个数,只不过是a[i]需要再次进行a[i]++的操作,与y安全没有关系。

防坑指南:
树状数组里面的下标是从1开始的,同时应该先计算新添加进来的星星的level,然后再跟新这个点对c[]数组的影响,这样会好一些



源代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<stack>
#include<queue>
#include<vector>
#include<deque>
#include<map>
#include<set>
#include<algorithm>
#include<string>
#include<iomanip>
#include<cstdlib>
#include<cmath>
#include<sstream>
#include<ctime>
using namespace std;

typedef long long ll;
#define eps 1e-6
#define e exp(1.0)
#define pi acos(-1.0)
const int MAXN = 32005;
const int INF = 0x3f3f3f3f;

int c[MAXN];
int level[MAXN];

int lowbit(int x)
{
    return x&(-x);
}

void add(int x, int num)
{
    while(x<=MAXN)
    {
        c[x]+=num;
        x+=lowbit(x);
    }
}

int sum(int x)
{
    int res = 0;
    while(x>0)
    {
        res+=c[x];
        x-=lowbit(x);
    }
    return res;
}

int main()
{
    int t;
    int i,j,x,y;
    while(~scanf("%d",&t))
    {
        memset(level,0,sizeof(level));
        memset(c,0,sizeof(c));
        for(i = 0; i < t; i++)
        {
            scanf("%d%d",&x,&y);
            level[sum(x+1)]++;
            add(x+1,1);
        }
        for(j = 0; j < t; j++)
        {
            printf("%d\n",level[j]);
        }
    }
	return 0;
}


posted @ 2017-11-03 01:43  lemonsbiscuit  阅读(175)  评论(0编辑  收藏  举报