POJ-2785

4 Values whose Sum is 0
Time Limit: 15000MS   Memory Limit: 228000K
Total Submissions: 12224   Accepted: 3426
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

Source

 
二分法
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define maxn 4005
using namespace std;
int a[maxn],b[maxn],c[maxn],d[maxn];
int s1[maxn*maxn],s2[maxn*maxn];
int cur;
int ans;
void binary()
{
    ans=0;
    int i,j,k;
    for (i=0;i<cur;i++)
    {
        int now=s2[i];
        int l=0,r=cur-1,mid;
        while (l<=r)
        {
            mid=(l+r)/2;
            if (now+s1[mid]==0)
            {
              ans++;
              break;
            }
            if (now+s1[mid]<0) l=mid+1;
            else r=mid-1;
        }
        if (now+s1[mid]==0)
        {
            int tt=1;
            while (mid+tt<cur&&now+s1[mid+tt]==0){tt++;ans++;}
            tt=1;
            while (mid-tt>=0&&now+s1[mid-tt]==0){tt++;ans++;}
        }
    }
}
int main()
{
    int n;
    while (scanf("%d",&n)!=EOF)
    {
        int i,j,k;
        for (i=0;i<n;i++)
        {
            scanf("%d %d %d %d",&a[i],&b[i],&c[i],&d[i]);
        }
        cur=0;
        for (i=0;i<n;i++)
        {
            for (j=0;j<n;j++)
            {
                s1[cur]=a[i]+b[j];
                s2[cur++]=c[i]+d[j];
            }
        }
        //cout<<cur<<endl;
        sort(s1,s1+cur);
        binary();
        printf("%d\n",ans);
    }
    return 0;
}

 

posted @ 2013-01-23 09:52  KRisen  阅读(142)  评论(0编辑  收藏  举报