hdu A simple problem

A simple problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2488    Accepted Submission(s): 855

Problem Description
Zty很痴迷数学问题.。一天,yifenfei出了个数学题想难倒他,让他回答1 / n。但Zty却回答不了^_^. 请大家编程帮助他.
 

 

Input
第一行整数T,表示测试组数。后面T行,每行一个整数 n (1<=|n|<=10^5).
 

 

Output
输出1/n. (是循环小数的,只输出第一个循环节).
 

 

Sample Input
4 2 3 7 168
 

 

Sample Output
0.5 0.3 0.142857 0.005952380
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 100001
int a[N];
int main(){
	int k,n,T;
	scanf("%d",&T);
	while(T--){
		scanf("%d",&n);
		if(n<0){printf("-");n=-n;}
		if(n==1){printf("1");continue;}
		printf("0.");
		memset(a,0,sizeof(a));
		a[0]=1;
		k=1;
		while(!a[k]){//余数第一次出现,没有出现循环
			    a[k]=1;
				k*=10;
				printf("%d",k/n);
				k%=n;
		}
		printf("\n");
	}
return 0;
}

posted @ 2013-05-11 20:35  坚固66  阅读(135)  评论(0编辑  收藏  举报