hdu 2844 Coins 解题报告

链接:http://acm.hdu.edu.cn/showproblem.php?pid=2844

Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 


Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 


Output
For each test case output the answer on a single line.
 


Sample Input
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 


Sample Output
8 4
初看此题首先想到了母函数,但在背包的专题里看到的就用背包写吧,母函数的题基本上都可以用背包做的
#include <stdio.h>
#include <string.h>
#define Max 100005
#define max( a, b ) a>b?a:b
int w[Max], v[Max], n[Max], f[Max], N, M, k;

void zpack( int v, int w )
{
	for( int i=M; i >= w; -- i )
		f[i]=max( f[i], f[i-w]+v );	
}

void cpack( int v, int w )
{
	for( int i=w; i <= M; ++ i )
		f[i]=max( f[i], f[i-w]+v );	
}

int main(  )
{
	while( scanf( "%d%d", &N, &M ) != EOF, N+M )
	{
		for( int i=1; i <= N; ++ i )
			scanf( "%d", &v[i] );
		for( int i=1; i <= N; ++ i )
			scanf( "%d", &n[i] );
		memset( f, 0, sizeof( f ) );
		for( int i=1; i <= N; ++ i )
		{
			if( n[i]*v[i]>=M )
				cpack( v[i], v[i] );
			else
			{
				k=1;
				while( k <= n[i] )
				{
					zpack( k*v[i], k*v[i] );
					n[i]-=k;
					k <<= 1;		
				}
				zpack( n[i]*v[i], n[i]*v[i] ); 
			}
		}
		int ans=0;
		for( int i=1; i <= M; ++ i )
		{
			if( f[i] == i )
				ans++;	
		} 
		printf( "%d\n", ans ); 
			
	}	
}

  

posted @ 2011-08-11 14:46  淡墨æ末央  阅读(470)  评论(0编辑  收藏  举报