坦然玲子  

1 秒

内存限制:128 兆

特殊判题:

提交:794

解决:77

题目描述:

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

输入:

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero and less than 10000.

输出:

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

样例输入:
6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1
样例输出:
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
来源:
2012年北京大学计算机研究生机试真题
 
CODE:

#include<iostream>
#include<stack>
#include<cstdio>
using namespace std;
typedef struct Node{
  int id;
  struct Node * next;      
}N;

stack<int> s;
N t[10000];
int c[10000];
int dfs(int m)
{
    struct Node * p;
    int flag;
    p=&t[m];
    flag=p->id;
    p=p->next;
    while(p)
    {
      if(p->id==flag)
        return 0;
       p=p->next;       
    }
   return 1; 
}
int main()
{
   int a,b,i,k,n=1,flag;
  
   while(1)
   { 
      scanf("%d%d",&a,&b);
      if(a==-1&&b==-1)
               break;
      flag=1;
      for(i=0; i<10000; i++)
        {
           t[i].id=i;
           c[i]=0;
           t[i].next=NULL;        
        }       
      k=a;
     while(a+b!=0)
      {      
          t[a].next=&t[b];
          c[b]++;//顶点入度 加一
          scanf("%d%d",&a,&b);                             
      }
    for(i=0; i<10000; i++)
     if(c[i]>1)
      flag=0;
     if(dfs(k)&&flag==1)//如果没有环且每个顶点的入度都不大于一
          printf("Case %d is a tree.\n",n++);
        else  printf("Case %d is not a tree.\n",n++);
  }
    
  return 0;      
}

posted on 2013-03-29 17:40  坦然玲子  阅读(204)  评论(0编辑  收藏  举报