最长公共子序列

时间限制:3000 ms  |  内存限制:65535 KB
难度:3
 
描述
咱们就不拐弯抹角了,如题,需要你做的就是写一个程序,得出最长公共子序列。
tip:最长公共子序列也称作最长公共子串(不要求连续),英文缩写为LCS(Longest Common Subsequence)。其定义是,一个序列 S ,如果分别是两个或多个已知序列的子序列,且是所有符合此条件序列中最长的,则 S 称为已知序列的最长公共子序列。
 
输入
第一行给出一个整数N(0<N<100)表示待测数据组数
接下来每组数据两行,分别为待测的两组字符串。每个字符串长度不大于1000.
输出
每组测试数据输出一个整数,表示最长公共子序列长度。每组结果占一行。
样例输入
2 asdf adfsd 123abc abc123abc
样例输出
3 6
//最长公共子序列
#include<stdio.h>
#include<string.h>
int maxc[1002][1002];
int main()
{
 char s1[1002],s2[1002];
 int len1,len2,i,j,n;
 scanf("%d",&n);
 while(n--)
 {
  memset(maxc,0,sizeof(maxc));
  scanf("%s",s1);
  scanf("%s",s2);
  len1=strlen(s1);
  len2=strlen(s2);
  for(i=1;i<=len1;++i)
  {
   for(j=1;j<=len2;++j)
   {
    if(s1[i-1]==s2[j-1])
     maxc[i][j]=maxc[i-1][j-1]+1;
    else
     maxc[i][j]=maxc[i][j-1]>maxc[i-1][j]?maxc[i][j-1]:maxc[i-1][j];
   }
  }
  printf("%d\n",maxc[len1][len2]);
 }
 return 0;
}
posted on 2012-06-04 12:45  可笑痴狂  阅读(240)  评论(0编辑  收藏  举报