[解题报告]HDU 1321 Reverse Text

Reverse Text

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4132    Accepted Submission(s): 2363


Problem Description
In most languages, text is written from left to right. However, there are other languages where text is read and written from right to left. As a first step towards a program that automatically translates from a left-to-right language into a right-to-left language and back, you are to write a program that changes the direction of a given text. 
 

 

Input
The input contains several test cases. The first line contains an integer specifying the number of test cases. Each test case consists of a single line of text which contains at most 70 characters. However, the newline character at the end of each line is not considered to be part of the line.
 

 

Output
For each test case, print a line containing the characters of the input line in reverse order.
 

 

Sample Input
3 Frankly, I don't think we'll make much money out of this scheme. madam I'm adam
 

 

Sample Output
hcum ekam ll'ew kniht t'nod I ,ylknarF .emehcs siht fo tuo yenom mada m'I madam
 

 

Source
 

 

Recommend
Ignatius.L
 

 

 

 

顺序输入逆序打出即可

 

#include<stdio.h>
#include<string.h>
int main()
{
    char str[70];
    int n;
    scanf("%d",&n);
    getchar();//吸收回车
    while(n--)
    {
        int i;
        gets(str);
        for(i=strlen(str)-1;i>=0;i--)
            printf("%c",str[i]);
        printf("\n");
    }
    return 0;
}

 

posted @ 2013-05-16 21:50  三人木君  阅读(222)  评论(0编辑  收藏  举报