[解题报告]HDU 1093 A+B for Input-Output Practice (V)

A+B for Input-Output Practice (V)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34197    Accepted Submission(s): 23118


Problem Description
Your task is to calculate the sum of some integers.
 

 

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 
 

 

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
 

 

Sample Input
2 4 1 2 3 4 5 1 2 3 4 5
 

 

Sample Output
10 15
 

 

Author
lcy
 
 
 
 
直接根据HDU 1092改一下即可
 
#include<stdio.h>
int main()
{
    int n;
    int m;
    scanf("%d",&m);
    while(m--)
    {
        scanf("%d",&n);
        int sum=0;
        while(n--)
    {
        int a;
        scanf("%d",&a);
        sum+=a;
    }
    printf("%d\n",sum);
    }
    return 0;
}

 

posted @ 2013-03-26 19:28  三人木君  阅读(168)  评论(0编辑  收藏  举报