POJ 2352 Stars

因为输入是按y坐标升序的,对每个点统计在它左边的个数就是它的level(线段树);

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0
------------------------------------------------------------------
# include <stdio.h>
# include <string.h>

# define N 100005

int n, D;
int cnt[4 * N], num[N];

void update(int i)
{
    for ( ; i ^ 1; i >>= 1)
    {
        cnt[i >> 1] = cnt[i] + cnt[i ^ 1];
    }
}

int query(int s, int t)
{
    int ret;

    ret = 0;
    s += D-1, t += D+1;
    for ( ; s ^ t ^ 1; s >>= 1, t >>= 1)
    {
        if (~s & 0x1) ret += cnt[s+1];
        if ( t & 0x1) ret += cnt[t-1];
    }
    
    return ret;
}

void init(void)
{
    for (D = 1; D < N+2; D <<= 1) ;
    scanf("%d", &n);
    memset(cnt, 0, sizeof(cnt));
    memset(num, 0, sizeof(num));
}

void solve(void)
{
    int x, y, i;

    for (i = 1; i <= n; ++i)
    {
        scanf("%d%d", &x, &y);
        ++num[query(0, x)];
        ++cnt[D + x], update(x+D);
    }
    for (i = 0; i < n; ++i)
    {
        printf("%d\n", num[i]);
    }
}

int main()
{
    init();
    solve();

    return 0;
}
------------------------------------------------------------------

posted on 2012-07-12 09:48  getgoing  阅读(952)  评论(0编辑  收藏  举报

导航