POJ 1611 The Suspects 并查集

                                                                           The Suspects

 

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). Once a member in a group is a suspect, all members in the group are suspects. However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1
代码:
#include<cstdio>
#include<iostream>
#define M 50005
using namespace std ;
int fa[M] ;
int find( int x ){
	if( x != fa[x] )
		fa[x] = find(fa[x]) ;
	return fa[x] ;
}
void ab( int x , int y ){
	int xx = find(x) ;
	int yy = find(y) ;// 因为最后要查找的是有0 的一颗树 所以把父亲大的接到父亲小的上面 
	if( xx > yy ) 
		fa[xx] = yy ;
	else fa[yy] = xx ;
}

int main()
{
     int i , j , n ,m , k , sum , d ,v ;
	 while(scanf( "%d%d" , &n , &m ) != EOF ){
		 if( n == 0 && m == 0 ) break; 
		 sum = 0 ;
		 for( i = 0 ; i < n ;i++)
			 fa[i] = i ;
		 while( m-- ){
			 scanf( "%d%d" , &k , &v ) ;
			 for( j = 1 ;j < k ;j++){
				 scanf( "%d" , &i ) ;
				 ab( v , i ) ;//连接到一颗树上
			 }
		 }
		 for( i = 0 ; i < n ; i++)
			 if( find(i) == 0 ) sum++ ;//如果其父亲为0 则 + 1 
		 printf( "%d\n" , sum ) ;
	 } 
}

  

posted @ 2013-04-03 09:36  _log__  阅读(152)  评论(0编辑  收藏  举报