poj3177 Redundant Paths

Redundant Paths
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 16630   Accepted: 6935

Description

In order to get from one of the F (1 <= F <= 5,000) grazing fields (which are numbered 1..F) to another field, Bessie and the rest of the herd are forced to cross near the Tree of Rotten Apples. The cows are now tired of often being forced to take a particular path and want to build some new paths so that they will always have a choice of at least two separate routes between any pair of fields. They currently have at least one route between each pair of fields and want to have at least two. Of course, they can only travel on Official Paths when they move from one field to another.

Given a description of the current set of R (F-1 <= R <= 10,000) paths that each connect exactly two different fields, determine the minimum number of new paths (each of which connects exactly two fields) that must be built so that there are at least two separate routes between any pair of fields. Routes are considered separate if they use none of the same paths, even if they visit the same intermediate field along the way.

There might already be more than one paths between the same pair of fields, and you may also build a new path that connects the same fields as some other path.

Input

Line 1: Two space-separated integers: F and R

Lines 2..R+1: Each line contains two space-separated integers which are the fields at the endpoints of some path.

Output

Line 1: A single integer that is the number of new paths that must be built.

Sample Input

7 7
1 2
2 3
3 4
2 5
4 5
5 6
5 7

Sample Output

2

Hint

Explanation of the sample:

One visualization of the paths is:
   1   2   3
+---+---+
| |
| |
6 +---+---+ 4
/ 5
/
/
7 +
Building new paths from 1 to 6 and from 4 to 7 satisfies the conditions.
   1   2   3
+---+---+
: | |
: | |
6 +---+---+ 4
/ 5 :
/ :
/ :
7 + - - - -
Check some of the routes:
1 – 2: 1 –> 2 and 1 –> 6 –> 5 –> 2
1 – 4: 1 –> 2 –> 3 –> 4 and 1 –> 6 –> 5 –> 4
3 – 7: 3 –> 4 –> 7 and 3 –> 2 –> 5 –> 7
Every pair of fields is, in fact, connected by two routes.

It's possible that adding some other path will also solve the problem (like one from 6 to 7). Adding two paths, however, is the minimum.

Source

题目大意:给一个无向图,问最少加多少条边使得图变成双连通图.
分析:先把所有的双连通分量缩成一个点,剩下的边就是桥边,最终一定会变成一棵树.接下来的操作是每次选两个叶子节点连起来,如果有ans个叶子结点,那么就需要连(ans + 1)/2条边,这就是答案了.

          具体的实现需要在tarjan算法中加一个id数组表示第一条到达第i个点的编号是多少,一开始将tot设为2,就能非常方便的通过^1得到反向边.在对无向图进行tarjan算法处理的时候一定要注意当前走的边是不是上一次走的反向边,也就是不能走回父亲节点.将所有的桥给标出来,然后剩下的边就全在双连通分量里了.枚举每条边,如果当前的边不是桥,就合并边所连的两点,利用并查集维护.最后判断叶子节点:枚举所有的点,如果当前点所在的双连通分量的度数为1,则为叶子节点.

#include <cstdio>
#include <stack>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int maxn = 20010;
int n,m,fa[maxn],ans,head[maxn],to[maxn],nextt[maxn],tot = 2,from[maxn];
int pre[maxn],low[maxn],dfs_clock,flag[maxn],id[maxn],du[maxn];
stack <int> s;

void add(int x,int y)
{
    to[tot] = y;
    from[tot] = x;
    nextt[tot] = head[x];
    head[x] = tot++;
}

int find(int x)
{
    if (fa[x] == x)
        return x;
    return fa[x] = find(fa[x]);
}

void tarjan(int u)
{
    pre[u] = low[u] = ++dfs_clock;
    for (int i = head[u];i;i = nextt[i])
    {
        if (i == (id[u] ^ 1))
            continue;
        int v = to[i];
        if (!pre[v])
        {
            id[v] = i;
            tarjan(v);
            if (low[v] < low[u])
                low[u] = low[v];
            if (low[v] > pre[u])
                flag[id[v]] = flag[id[v] ^ 1] = 1;
        }
        else
            low[u] = min(low[u],pre[v]);
    }
}

void hebing(int x,int y)
{
    int fx = find(x),fy = find(y);
    if (fx != fy)
        fa[fx] = fy;
}

int main()
{
    scanf("%d%d",&n,&m);
    for (int i = 1; i <= n; i++)
        fa[i] = i;
    for (int i = 1; i <= m; i++)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        add(a,b);
        add(b,a);
    }
    for (int i = 1; i <= n; i++)
        if (!pre[i])
            tarjan(i);
    for (int i = 2; i < tot; i += 2)
        if (!flag[i])
            hebing(from[i],to[i]);
    for (int i = 2; i < tot; i += 2)
        if (flag[i])
    {
        du[find(from[i])]++;
        du[find(to[i])]++;
    }
    for (int i = 1; i <= n; i++)
        if (find(i) == i && du[find(i)] == 1)
        ans++;
    printf("%d\n",(ans + 1) / 2);

    return 0;
}

 

 

posted @ 2017-12-15 16:22  zbtrs  阅读(181)  评论(0编辑  收藏  举报