hdu Rescue

算法:搜索

题意:要求天使的朋友在最短的时间内救出天使,a代表天使,r代表天使的朋友,.代表路,#代表墙,x代表小兵,

每走一步需要一个时间,遇到小兵杀了他要一个时间,移到小兵的位置有要一个时间;

输出最短的时间,

如果救不出来就输出

Poor ANGEL has to stay in the prison all his life.

Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)


Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.


Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."


Sample Input
7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........


Sample Output
13

代码:

#include <iostream>
#include <algorithm>
#include <string>
#include <iomanip>
#include <cstring>
#include <stdio.h>
#define INF 100000
using namespace std;
char ch[205][205];
int a[205][205],n,m,k,q=-1,p=-1;
int b[4][2]={-1,0,1,0,0,-1,0,1};
void dfs(int x,int y)
{   int j=0;
	if(x==p&&y==q) return;
	else
	{
		for(int i=0;i<4;i++)
		{
			int dx=x+b[i][0];
			int dy=y+b[i][1];
			if(dx>=0&&dx<n&&dy>=0&&dy<m&&ch[dx][dy]=='.'||ch[dx][dy]=='x')
			{
				if(ch[dx][dy]=='.')
				{
					ch[dx][dy]='#';
					a[dx][dy]=min(a[x][y]+1,a[dx][dy]);
					dfs(dx,dy);
					ch[dx][dy]='.';
				}
				else if(ch[dx][dy]=='x')
				{
				    ch[dx][dy]='#';
					a[dx][dy]=min(a[x][y]+2,a[dx][dy]);
					dfs(dx,dy);
					ch[dx][dy]='x';	
				}
			}
			else j++;
		}
		if(j==4) return ;
	}
}  
int main()
{
	int i,j,s,t;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=0;i<n;i++)
		{
			for(j=0;j<m;j++)
			{
		 		cin>>ch[i][j];
				a[i][j]=INF;
				if(ch[i][j]=='a')
				{
					s=i;t=j;
					ch[i][j]='#';
				}
				if(ch[i][j]=='r')
				{
				    p=i;q=j;
					ch[i][j]='.';	
				}
			}
		}
		a[s][t]=0;
		dfs(s,t);
		if(a[p][q]==INF) printf("Poor ANGEL has to stay in the prison all his life.\n");
		else printf("%d\n",a[p][q]);
	}
	return 0;
}


  

posted @ 2015-12-11 18:37  (慎独)  阅读(186)  评论(0编辑  收藏  举报