poj 1159 Palindrome

Palindrome
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 59094   Accepted: 20528

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

 
题意:
给一串字符,问最少加多少个字符可以使它变成回文字符串。
(回文字符串=从左往右看 和 从右往左看 串相同)
 
short数组直接过
/* f[i][j]表示从字符标号i-j 变成回文串需要的最少步数
  不难得出
  若s[j]==s[i+j] : f[j][i+j]=f[j+1][i+j-1],
  否则 : f[j][i+j]=min(f[j+1][i+j],f[j][i+j-1])+1
*/
#include<cstdio>
#include<iostream>
using namespace std;
#define N 5010
char s[N];int n;
short int f[N][N];
int main(){
    scanf("%d%s",&n,s);
    for(int i=1;i<=n;i++){
        f[i][i]=0;f[i][i+1]=s[i]==s[i+1]?0:1;//初始化
    }
    for(int i=1;i<=n;i++){//循环两个字母的间隔 
        for(int j=0;i+j<n;j++){//循环开端字母
            if(s[j]==s[i+j]) f[j][i+j]=f[j+1][i+j-1];
            else f[j][i+j]=min(f[j+1][i+j],f[j][i+j-1])+1;
        }
    }
    printf("%d\n",f[0][n-1]);
    return 0;
}

 

posted @ 2016-05-15 16:59  神犇(shenben)  阅读(217)  评论(0编辑  收藏  举报