【01背包】——hdu2602

                                     Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 48749    Accepted Submission(s): 20324


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
 

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

 

Sample Output
14
 
代码如下:
#include<iostream>
#include<string.h>
using namespace std;

int c[1005];
int w[1005];
int dp[1005];

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(dp,0,sizeof(dp));

        int n,v,maxv=-1;
        cin>>n>>v;

        for(int i=0;i<n;i++)
            cin>>w[i];
        for(int i=0;i<n;i++)
            cin>>c[i];

        for(int i=0;i<n;i++)
        {
            for(int j=v;j>=c[i];j--)
            {
                if(dp[j-c[i]]+w[i]>dp[j])
                    dp[j]=dp[j-c[i]]+w[i];
            }
        }

        for(int i=v;i>=0;i--)
        {
            maxv=max(maxv,dp[i]);
        }
        cout<<maxv<<endl;
    }
}

 

posted @ 2016-06-22 17:34  琥珀川||雨露晨曦  阅读(128)  评论(0编辑  收藏  举报