HDU 1727 Hastiness(模拟)

Hastiness

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1793 Accepted Submission(s): 693

Problem Description
How many problems did you AC?
When you read this problem, don’t hasty and careless, this is also simple, haha, I didn’t cheat you.
The game over soon, WisKey starts using English begin countdown. He not only have no gene in math, but also bad in English. Fortunately, He met you who have gift in programming. So please help him to translate.

Input
Give you an integer T, output T in English, and note that all of words are lower case. (0<=T<=9999)

Output
One answer One line.
Details see sample.

Sample Input
2034
1234
123
24
0


Sample Output
two thousand and thirty-four
one thousand and two hundred and thirty-four
one hundred and twenty-three
twenty-four
zero


Author
威士忌


Source
HZIEE 2007 Programming Contest

模拟模拟,

*#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    char a[100][100];
    strcpy(a[0],"zero");
    strcpy(a[1],"one");
    strcpy(a[2],"two");
    strcpy(a[3],"three");
    strcpy(a[4],"four");
    strcpy(a[5],"five");
    strcpy(a[6],"six");
    strcpy(a[7],"seven");
    strcpy(a[8],"eight");
    strcpy(a[9],"nine");
    strcpy(a[10],"ten");
    strcpy(a[11],"eleven");
    strcpy(a[12],"twelve");
    strcpy(a[13],"thirteen");
    strcpy(a[14],"fourteen");
    strcpy(a[15],"fifteen");
    strcpy(a[16],"sixteen");
    strcpy(a[17],"seventeen");
    strcpy(a[18],"eighteen");
    strcpy(a[19],"nineteen");
    strcpy(a[20],"twenty");
    strcpy(a[30],"thirty");
    strcpy(a[40],"forty");
    strcpy(a[50],"fifty");
    strcpy(a[60],"sixty");
    strcpy(a[70],"seventy");
    strcpy(a[80],"eighty");
    strcpy(a[90],"ninety");
    int k,x,y,z,t;
    while(scanf("%d",&k)!=EOF)
    {
        if(k/1000!=0)
        {
            x=k/1000;
            printf("%s thousand",a[x]);
            y=k/100%10;
            if(y!=0)
                printf(" and %s hundred",a[y]);
            z=k/10%10;
            t=k%10;
            if(z==0)
            {
                if(t==0)
                    {printf("\n");continue;}
                printf(" and %s\n",a[t]);
                continue;
            }
            else if(z==1)
            {
                z=k%100;
                printf(" and %s\n",a[z]);
                continue;
            }
            else
            {
                 if(t==0)
                    {printf(" and %s\n",a[k%100]);continue;}
                printf(" and %s-%s\n",a[z*10],a[t]);
                continue;
            }
        }
        else if(k/100!=0)
        {
            y=k/100%10;
            if(y!=0)
                printf("%s hundred",a[y]);
            z=k/10%10;
            t=k%10;
            if(z==0)
            {
                if(t==0)
                    {printf("\n");continue;}
                printf(" and %s\n",a[t]);
                continue;
            }
            else if(z==1)
            {
                z=k%100;
                printf(" and %s\n",a[z]);
                continue;
            }
            else
            {
                if(t==0)
                    {printf(" and %s\n",a[k%100]);continue;}
                printf(" and %s-%s\n",a[z*10],a[t]);
                continue;
            }
        }
        else if(k/10!=0)
        {
            z=k/10%10;
            t=k%10;
            if(z==0)
            {
                if(t==0)
                    {printf("\n");continue;}
                printf("%s\n",a[t]);
                continue;
            }
            else if(z==1)
            {
                z=k%100;
                printf("%s\n",a[z]);
                continue;
            }
            else
            {
                if(t==0)
                    {printf("%s\n",a[k%100]);continue;}
                printf("%s-%s\n",a[z*10],a[t]);
                continue;
            }
        }
        else
            printf("%s\n",a[k]);
    }
    return 0;
}
posted @ 2017-11-18 16:56  南风古  阅读(136)  评论(0编辑  收藏  举报