HDU 1003 Max Sum

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1003

题意:找出最大连续项的和。

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 192179    Accepted Submission(s): 44762


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

 

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
 

 

Author
Ignatius.L
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>

using namespace std;

const int maxn = 100005;

int main()
{
    int t, n, Max;
    scanf("%d",&t);
    int k=1;
    while(t--)
    {
        scanf("%d",&n);
        scanf("%d",&Max);
        int sum = Max;
        int s=1, e=1, x;
        int S=1, E=1;
        for(int i=2; i<=n; i++)
        {
            scanf("%d",&x);
            if(sum+x < x)
            {
                sum = x;
                s = i;
                e = i;
            }
            else
            {
                e = i;
                sum = sum + x;
            }
            if(sum > Max)
            {
                Max = sum;
                S = s;
                E = e;
            }
        }

        printf("Case %d:\n",k++);
        printf("%d %d %d\n",Max,S,E);
        if(t!=0)
        {
            printf("\n");
        }
    }

    return 0;
}

 

posted @ 2015-12-09 16:01  梦中。。  阅读(114)  评论(0编辑  收藏  举报