Vim-Vundle-plugins-scripts

配置文件.vimrc

 1 set tabstop=4
 2 set softtabstop=4
 3 set shiftwidth=4
 4 set noexpandtab
 5 set autoindent
 6 set cindent
 7 set backspace=2
 8 set nu
 9 
10 set nocompatible            " be iMproved, required
11 filetype off                " required
12 
13 " set the runtime path to include Vundle and initialize
14 set rtp+=~/.vim/bundle/Vundle.vim
15 call vundle#begin()
16 
17 " let Vundle manage Vundle, required
18 Plugin 'VundleVim/Vundle.vim'
19 
20 " Keep Plugin commands between vundle#begin/end.
21 Plugin 'bling/vim-airline'
22 Plugin 'kien/ctrlp.vim'
23 Plugin 'scrooloose/nerdtree'
24 Plugin 'scrooloose/nerdcommenter'
25 Plugin 'derekwyatt/vim-scala'
26 Plugin 'tpope/vim-surround'
27 Plugin 'Valloric/YouCompleteMe'
28 Plugin 'jiangmiao/auto-pairs'
29 Plugin 'christoomey/vim-tmux-navigator'
30 Plugin 'altercation/vim-colors-solarized'
31 Plugin 'chriskempson/vim-tomorrow-theme'
32 Plugin 'octol/vim-cpp-enhanced-highlight'
33 
34 " All of your Plugins must be added before the following line
35 call vundle#end()            " required
36 filetype plugin indent on    " required
37 " To ignore plugin indent changes, instead use:
38 "filetype plugin on
39 "
40 " Brief help
41 " :PluginList       - lists configured plugins
42 " :PluginInstall    - installs plugins; append `!` to update or just :PluginUpdate
43 " :PluginSearch foo - searches for foo; append `!` to refresh local cache
44 " :PluginClean      - confirms removal of unused plugins; append `!` to auto-approve removal
45 "
46 " see :h vundle for more details or wiki for FAQ
47 " Put your non-Plugin stuff after this line

Reference:

Vundle install : https://github.com/VundleVim/Vundle.vim

YouYompleteMe : https://github.com/Valloric/YouCompleteMe#ubuntu-linux-x64

posted @ 2016-04-02 17:47 loadofleaf Views(...) Comments(...) Edit 收藏