hdu2444The Accomodation of Students (最大匹配+推断是否为二分图)

The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2244 Accepted Submission(s): 1056


Problem Description
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.


Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.

Sample Input
4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6

Sample Output
No 3
题意:首先推断全部的人可不能够分成两部分,每部分内的全部人都相互不认识。

假设能够分成 则求两部分最多相互认识的对数。

解题:是否能分成两部分 则是推断是否是一个二分图。
无向图G为二分图的充分必要条件是:G至少有两个顶点,且当存在回路时。其全部回路的长度均为偶数。回路就是环路。也就是推断是否存在奇数环。
推断二分图方法:用染色法,把图中的点染成黑色和白色。
首先取一个点染成白色。然后将其相邻的点染成黑色,假设发现有相邻且同色的点,那么就退出。可知这个图并不是二分图。

#include<stdio.h>
#include<string.h>
#include<queue>
#include<iostream>
using namespace std;
int map[205][205],vist[205],match[205],n;
int find(int i)
{
    for(int j=1;j<=n;j++)
    if(!vist[j]&&map[i][j])
    {
        vist[j]=1;
        if(match[j]==0||find(match[j]))
        {
            match[j]=i; return 1;
        }
    }
    return 0;
}
int isTwo()//推断是否为二分图
{
    queue<int>q;
    memset(vist,0,sizeof(vist));
        q.push(1); vist[1]=1;
        while(!q.empty())
        {
            int p=q.front(); q.pop();
            for(int j=1;j<=n;j++)
            if(map[p][j])
            {
                if(vist[j]==0)
                {
                    if(vist[p]==1)vist[j]=2;else vist[j]=1;
                    q.push(j);
                }
                else if(vist[j]==vist[p])
                    return 0;
            }
        }
    return 1;
}
int main()
{
    int m,a,b;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(map,0,sizeof(map));
        while(m--)
        {
            scanf("%d%d",&a,&b);
            map[a][b]=map[b][a]=1;
        }
        if(!isTwo()||n==1)
        {
            printf("No\n"); continue;
        }
        memset(match,0,sizeof(match));
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            memset(vist,0,sizeof(vist));
            ans+=find(i);
        }
        printf("%d\n",ans/2);//除2是由于对称,1认识2 与 2认识1 属同一情况
    }
}


posted @ 2016-04-17 20:40  lcchuguo  阅读(167)  评论(0编辑  收藏  举报