HDU 1108 最小公倍数

最小公倍数

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54839    Accepted Submission(s): 30403


Problem Description
给定两个正整数,计算这两个数的最小公倍数。
 

 

Input
输入包含多组测试数据,每组只有一行,包括两个不大于1000的正整数.
 

 

Output
对于每个测试用例,给出这两个数的最小公倍数,每个实例输出一行。
 

 

Sample Input
10 14
 

 

Sample Output
70
 

 

Source
水题~求最小公倍数  注意最小公倍数,如求a,b的最小公倍数就是  (a*b)/gcd(a,b)
gcd是求最大公约数的一个函数,要自己手写
int gcd(int a,int b)
{
    if(a==0)
        return b;
    if(b==0)
        return a;
    return gcd(b,a%b);
}//求最大公约数
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
int f(int a,int b)
{
    if(a==0)
        return b;
    if(b==0)
        return a;
    return f(b,a%b);
}
int main()
{
    int a,b;
    while(~scanf("%d%d",&a,&b))
    {
        printf("%d\n",(a*b)/f(a,b));//求最小公倍数
    }
    return 0;
}

 

posted on 2017-03-21 19:43  九月旧约  阅读(181)  评论(0编辑  收藏  举报

导航