POJ 2398 Toy Storage(计算几何,叉积判断点和线段的关系)

Toy Storage
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3146   Accepted: 1798

Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:

We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

Source

 
 
这题和POJ 2318 是一样的
就是最后输出的内容不一样而已。
 
/************************************************************
 * Author        : kuangbin
 * Email         : kuangbin2009@126.com 
 * Last modified : 2013-07-13 17:15
 * Filename      : POJ2398TOYStorage.cpp
 * Description   : 
 * *********************************************************/

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <map>
#include <vector>
#include <set>
#include <string>
#include <math.h>

using namespace std;
struct Point
{
    int x,y;
    Point(){}
    Point(int _x,int _y)
    {
        x = _x;y = _y;
    }
    Point operator -(const Point &b)const
    {
        return Point(x - b.x,y - b.y);
    }
    int operator *(const Point &b)const
    {
        return x*b.x + y*b.y;
    }
    int operator ^(const Point &b)const
    {
        return x*b.y - y*b.x;
    }
};
struct Line
{
    Point s,e;
    Line(){}
    Line(Point _s,Point _e)    
    {
        s = _s;e = _e;
    }
};

int xmult(Point p0,Point p1,Point p2) //计算p0p1 X p0p2
{
    return (p1-p0)^(p2-p0);
}
const int MAXN = 5050;
Line line[MAXN];
int ans[MAXN];
int num[MAXN];
bool cmp(Line a,Line b)
{
    return a.s.x < b.s.x;
}
int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int n,m,x1,y1,x2,y2;
    while(scanf("%d",&n) == 1 && n)
    {
        scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
        int Ui,Li;
        for(int i = 0;i < n;i++)
        {
            scanf("%d%d",&Ui,&Li);
            line[i] = Line(Point(Ui,y1),Point(Li,y2));
        }
        line[n] = Line(Point(x2,y1),Point(x2,y2));
        sort(line,line+n+1,cmp);
        int x,y;
        Point p;
        memset(ans,0,sizeof(ans));
        while( m-- )
        {
            scanf("%d%d",&x,&y);
            p = Point(x,y);
            int l = 0,r = n;
            int tmp;
            while( l <= r)
            {
                int mid = (l + r)/2;
                if(xmult(p,line[mid].s,line[mid].e) < 0)
                {
                    tmp = mid;
                    r = mid - 1;
                }
                else l = mid + 1;
            }
            ans[tmp]++;
        }
        for(int i = 1;i <= n;i++)
            num[i] = 0;
        for(int i = 0;i <= n;i++)
            if(ans[i]>0)
                num[ans[i]]++;
        printf("Box\n");
        for(int i = 1;i <= n;i++)
            if(num[i]>0)
                printf("%d: %d\n",i,num[i]);
    }
    return 0;
}

 

 

posted on 2013-07-13 20:13  kuangbin  阅读(1839)  评论(0编辑  收藏  举报

导航

JAVASCRIPT: