junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Cow Exhibition
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12800   Accepted: 5121

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 

Source

参考:kuangbin的博客。

将任意一方当成价值,另一方当成代价,用01背包解决,由于下标不能为负值,所以向右移动100000,由于要恰好装满,dp[100000]=0,dp[else] = -∞。

# include <stdio.h>
# include <string.h>
# define INF 0x3f3f3f3f
# define MAXN 200000
int dp[MAXN+1];
int main()
{
    int i, j, n, max_v=0, imax=-1, v[101], c[101];
    for(i=0; i<=MAXN; ++i)
        dp[i] = -INF;
    dp[100000] = 0;
    scanf("%d",&n);
    for(i=0; i<n; ++i)
        scanf("%d%d",&v[i],&c[i]);
    for(i=0; i<n; ++i)
    {
        if(c[i]>=0)
        {
            for(j=MAXN; j>=c[i]; --j)
                if(dp[j-c[i]] != -INF && dp[j-c[i]]+v[i] > dp[j])
                    dp[j] = dp[j-c[i]]+v[i];
        }
        else
        {
            for(j=0; j<=MAXN+c[i]; ++j)
                if(dp[j-c[i]] != -INF && dp[j-c[i]]+v[i] > dp[j])
                    dp[j] = dp[j-c[i]]+v[i];
        }
    }
    for(i=100000; i<=MAXN; ++i)
        if(dp[i]>=0 && i+dp[i]-100000 > imax)
            imax = i+dp[i]-100000;
    printf("%d\n",imax);

    return 0;
}




posted on 2017-01-14 21:15  junior19  阅读(111)  评论(0编辑  收藏  举报