POJ-1028(字符串模拟)

Web Navigation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 31906   Accepted: 14242

Description

Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this.
The following commands need to be supported:
BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored.
FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored.
VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied.
QUIT: Quit the browser.
Assume that the browser initially loads the web page at the URL http://www.acm.org/

Input

Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.

Output

For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

Sample Input

VISIT http://acm.ashland.edu/
VISIT http://acm.baylor.edu/acmicpc/
BACK
BACK
BACK
FORWARD
VISIT http://www.ibm.com/
BACK
BACK
FORWARD
FORWARD
FORWARD
QUIT

Sample Output

http://acm.ashland.edu/
http://acm.baylor.edu/acmicpc/
http://acm.ashland.edu/
http://www.acm.org/
Ignored
http://acm.ashland.edu/
http://www.ibm.com/
http://acm.ashland.edu/
http://www.acm.org/
http://acm.ashland.edu/
http://www.ibm.com/
Ignored

思路:
终于通过这道题目尝试了下C++里面的string类,结果发现尼玛和java里面的完全没两样啊
没有太大的难度,就是按照题目的操作模拟一下就可以,有个地方第一次提交的时候出错了,就是BACK和FORWARD这两种情况
当stack为空的时候,他们是不会把tmp_url压进栈的,这点一开始没有注意到,debug一下就发现了
还有一开始准备用switch,结果发现这个函数只能够对int型变量操作

#include <iostream>
#include <stack>
#include <string>
using namespace std;

int main()
{
    string command;
    stack<string> f,b;
    string tmp_url = "http://www.acm.org/";
    string new_url;
    
    while(cin>>command) {
        if(command == "VISIT") {
            b.push(tmp_url);
            cin>>tmp_url;
            while(!f.empty()){f.pop();}
            cout<<tmp_url<<endl;
        }
        if(command == "BACK") {
            if(!b.empty()) {
                f.push(tmp_url);
                tmp_url = b.top();
                b.pop();
                cout<<tmp_url<<endl;
            }
            else {
                cout<<"Ignored"<<endl;
            }    
        }
        if(command == "FORWARD") {
            if(!f.empty()) {
                b.push(tmp_url);
                tmp_url = f.top();
                f.pop();
                cout<<tmp_url<<endl;
            }
            else {
                cout<<"Ignored"<<endl;
            }    
        }
        if(command == "QUIT")
            break;
    }
    return 0;
}
posted @ 2015-12-08 09:03  Miller_S  阅读(779)  评论(0编辑  收藏  举报