HDU 1008:Elevator

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 58782    Accepted Submission(s): 32253


Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case. 
 

Sample Input
1 2 3 2 3 1 0
 

Sample Output
17 41
 

Author
ZHENG, Jianqiang
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1003 1108 1019 1012 1049 
 

你  离  开  了  ,  我  的  世  界  里  只  剩  下  雨  。  。  。

#include<stdio.h>
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        int ma=0,d,m=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&d);
            if(m<d)ma+=(d-m)*6+5;
            else if(d<m)ma+=(m-d)*4+5;
            else ma+=5;
            m=d;
        }
        printf("%d\n",ma);
    }
    return 0;
}

posted @ 2016-01-30 09:20  小坏蛋_千千  阅读(144)  评论(0编辑  收藏  举报