Live2d Test Env

ZOJ3329One Person Game(循环型 数学期望)

 

There is a very simple and interesting one-person game. You have 3 dice, namely Die1Die2 and Die3Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1K2K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

 

Input

 

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers nK1K2K3abc (0 <= n <= 500, 1 < K1K2K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

<b< dd="">

Output

 

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

 

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output

 

1.142857142857143
1.004651162790698

 题意:

有三个骰子,面值分别是k1,k2,k3。每次扔出的值之和加到ans上,问多少次才能ans>n;当然,当遇到k1=a,k2=b,k3=c时,ans=0;重新开始累加。

思路:

和之前Maze一个题型。写出的公式是有后续性的。我们需要弄一个递推公式,消去后续性。

本题通过代换系数,化简后求系数。

一般形成环的用高斯消元法求解。但是此题都是和dp[0]相关。所有可以分离出系数。
设dp[i]表示达到i分时到达目标状态的期望,pk为投掷k分的概率,p0为回到0的概率
则dp[i]=∑(pk*dp[i+k])+dp[0]*p0+1;
都和dp[0]有关系,而且dp[0]就是我们所求,为常数
设dp[i]=A[i]*dp[0]+B[i];
代入上述方程右边得到:
dp[i]=∑(pk*A[i+k]*dp[0]+pk*B[i+k])+dp[0]*p0+1
     =(∑(pk*A[i+k])+p0)dp[0]+∑(pk*B[i+k])+1;
     明显A[i]=(∑(pk*A[i+k])+p0)
     B[i]=∑(pk*B[i+k])+1
     先递推求得A[0]和B[0].
     那么  dp[0]=B[0]/(1-A[0]);

 

 

#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=1010;
double A[maxn],B[maxn],P[maxn];
int main()
{
    int T,n,k1,k2,k3,a,b,c,i,j,k;
    scanf("%d",&T);
    while(T--){
        memset(A,0,sizeof(A));memset(B,0,sizeof(B));memset(P,0,sizeof(P));
        scanf("%d%d%d%d%d%d%d",&n,&k1,&k2,&k3,&a,&b,&c);
        P[0]=1.0/k1/k2/k3;
        for(i=1;i<=k1;i++)
         for(j=1;j<=k2;j++)
          for(k=1;k<=k3;k++)
           if(!(i==a&&j==b&&k==c))
            P[i+j+k]+=P[0];
        for(i=n;i>=0;i--){
            A[i]=P[0];B[i]=1;
            for(j=1;j<=k1+k2+k3;j++)  A[i]+=P[j]*A[i+j];
            for(j=1;j<=k1+k2+k3;j++)  B[i]+=P[j]*B[i+j];
        }
        printf("%.15lf\n",B[0]/(1-A[0]));
    }
    return 0;
}

 

posted @ 2017-12-15 12:57  nimphy  阅读(785)  评论(0编辑  收藏  举报