http://acm.hust.edu.cn/vjudge/problem/35178 Floor problem

In this problem, we have f(n,x)=Floor[n/x]. Here Floor[x] is the biggest integer such that no larger than x. For example, Floor[1.1]=Floor[1.9]=1, Floor[2.0]=2.

 

You are given 3 positive integers n, L and R. Print the result of f(n,L)+f(n,L+1)+...+f(n,R), please.

Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 3 integers n, L and R (1≤n, L, R≤10,000, L≤R).

Output

For each test case, print the result of f(n,L)+f(n,L+1)+...+f(n,R) in a single line.       

Sample Input

3 1 2 3 100 2 100 100 3 100

Sample Output

0 382 332

#include<stdio.h>
int main()
{
    int T,n,L,R;
    scanf("%d",&T);
    while(T--)
    {
        int sum=0;
        scanf("%d%d%d",&n,&L,&R);
        for(int i=L;i<=R;i++)
        {
            sum=sum+n/i;
        }
        printf("%d\n",sum);
    }
    return 0;
}

这是一个我都能说水题的题你说它有多水!!!!!交几份对几份!!!!大水题啊!!!!

posted @ 2016-07-19 20:39  小小姐  阅读(85)  评论(0编辑  收藏  举报