A+B for Input-Output Practice (I)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 129829 Accepted Submission(s): 69922

Problem Description
Your task is to Calculate a + b.
Too easy?! Of course! I specially designed the problem for acm beginners.
You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim.

Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input
1 5
10 20

Sample Output
6
30

#include <iostream>
using namespace std;
int main (){
    int a,b;
    while (cin >> a>>b){
        cout <<a+b<<endl;    
    }    
    return 0;
} 

A+B for Input-Output Practice (II)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 97559 Accepted Submission(s): 62308

Problem Description
Your task is to Calculate a + b.

Input
Input contains an integer N in the first line, and then N lines follow. Each line consists of a pair of integers a and b, separated by a space, one pair of integers per line.

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input
2
1 5
10 20

Sample Output
6
30

#include <iostream>
using namespace std;
int main (){
    int n;
    cin >>n;
    while (n--){
        int a,b;
        cin >>a >>b;
        cout <<a+b<<endl;     
    }        
    return 0;
} 

A+B for Input-Output Practice (III)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 108194 Accepted Submission(s): 56933

Problem Description
Your task is to Calculate a + b.

Input
Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input
1 5
10 20
0 0

Sample Output
6
30

#include <iostream>
using namespace std;
int main (){
    int a,b;
    while (cin>>a>>b,a||b){
        cout<<a+b<<endl;                
    }        
    return 0;
}

A+B for Input-Output Practice (IV)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 99949 Accepted Submission(s): 52783

Problem Description
Your task is to Calculate the sum of some integers.

Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input
4 1 2 3 4
5 1 2 3 4 5
0

Sample Output
10
15

#include <iostream>
using namespace std;
int main (){
    int n;
    while (cin>>n,n){    
    int sum=0,num;
    while (n--){
        cin>>num;
        sum+=num;        
    }
    cout << sum <<endl;
}        
    return 0;
}

A+B for Input-Output Practice (V)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 74170 Accepted Submission(s): 49454

Problem Description
Your task is to calculate the sum of some integers.

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input
2
4 1 2 3 4
5 1 2 3 4 5

Sample Output
10
15

#include <iostream>
using namespace std;
int main (){
    int n;
    while (cin>>n,n){    
    int sum=0,num;
    while (n--){
        cin>>num;
        sum+=num;        
    }
    cout << sum <<endl;
}        
    return 0;
}

A+B for Input-Output Practice (VI)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 69477 Accepted Submission(s): 46476

Problem Description
Your task is to calculate the sum of some integers.

Input
Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line.

Output
For each test case you should output the sum of N integers in one line, and with one line of output for each line in input.

Sample Input
4 1 2 3 4
5 1 2 3 4 5

Sample Output
10
15

#include <iostream>
using namespace std;
int main (){
    int n,num;
    while (cin >> n){
        int sum = 0;
        for (int i = 1;i <= n;i ++){        
        cin >> num;
        sum += num;
    }
        cout << sum << endl;
    }
    return 0;
}

A+B for Input-Output Practice (VII)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 68666 Accepted Submission(s): 45664

Problem Description
Your task is to Calculate a + b.

Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.

Output
For each pair of input integers a and b you should output the sum of a and b, and followed by a blank line.

Sample Input
1 5
10 20

Sample Output
6

30

#include <iostream>
using namespace std;
int main (){
    int a,b;
    while (cin >> a >> b){
        cout << a+b << endl << endl;        
    }            
    return 0;
}

A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 149649 Accepted Submission(s): 45273

Problem Description
Your task is to calculate the sum of some integers.

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

Sample Output
10

15

6

#include <iostream>
using namespace std;
int main (){
    int n;
    cin >> n;
    while (n--){
        int t,sum = 0,num;
        cin >> t;
        for (int i = 1;i <= t;i++){
            cin >> num;
            sum += num;
        }
        cout << sum << endl;
        if (n)    cout<< endl ;
    }    
    return 0;
}