ZOJ 3471 Most Powerful 【状态压缩DP】

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

Output

Output the maximal power these N atoms can produce in a line for each case.

Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

Sample Output

4
22

code:

View Code
不超过10种气体,两两之间相互碰撞可以产生一定的能量,如a碰b,那么b气体就消失,自身不能碰自身,问最后所能得到的最大能量。

用10位二进制表示气体是否存在,0表示存在,1表示不存在,S(上一个状态)中的两种气体碰撞并且有一种消失,可以得到newS的状态(状态转移)

状态 dp[state] 状态为state时的最大能量

转移 dp[state] = max(dp[state],dp[state']+a[i][j])

边界 dp[i] = 0;

#include<stdio.h>
#include<string.h>
#define max(a,b)(a)>(b)?(a):(b)
// dp[state]=dp[state2]+a[i][j];
int a[12][12];
int dp[1<<11];
int main()
{
int n,i,j,s;
while(scanf("%d",&n),n)
{
for(i=0;i<n;i++)
for(j=0;j<n;j++)
scanf("%d",&a[i][j]);
memset(dp,0,sizeof(dp));
int x=(1<<n);
for(s=0;s<x;s++)
{
for(i=0;i<n;i++)
{
if(s&(1<<i)) continue;
for(j=0;j<n;j++)
{
if(i==j||s&(1<<j)) continue;
int news=s|(1<<j);
dp[news]=max(dp[news],dp[s]+a[i][j]);
}
}
}
int res=0;
for(s=0;s<x;s++)
res=max(res,dp[s]);
printf("%d\n",res);
}
return 0;
}

 

posted @ 2012-04-01 20:03  'wind  阅读(420)  评论(0编辑  收藏  举报