POJ 2037 今年暑假不AC【贪心+DP】

Problem Description
“今年暑假不AC?”
“是的。”
“那你干什么呢?”
“看世界杯呀,笨蛋!”
“@#$%^&*%...”
确实如此,世界杯来了,球迷的节日也来了,估计很多ACMer也会抛开电脑,奔向电视了。
作为球迷,一定想看尽量多的完整的比赛,当然,作为新时代的好青年,你一定还会看一些其它的节目,比如新闻联播(永远不要忘记关心国家大事)、非常6+7、超级女生,以及王小丫的《开心辞典》等等,假设你已经知道了所有你喜欢看的电视节目的转播时间表,你会合理安排吗?(目标是能看尽量多的完整节目)
Input
输入数据包含多个测试实例,每个测试实例的第一行只有一个整数n(n<=100),表示你喜欢看的节目的总数,然后是n行数据,每行包括两个数据Ti_s,Ti_e (1<=i<=n),分别表示第i个节目的开始和结束时间,为了简化问题,每个时间都用一个正整数表示。n=0表示输入结束,不做处理。
Output
对于每个测试实例,输出能完整看到的电视节目的个数,每个测试实例的输出占一行。
Sample Input
12
1 3
3 4
0 7
3 8
15 19
15 20
10 15
8 18
6 12
5 10
4 14
2 9
0
Sample Output
5
方法一: DP 从后向前
code:
View Code
#include<stdio.h>
#include<stdlib.h>
struct node
{
int s;
int e;
int t;
}q[101];
int cmp(const void*p1,const void*p2)
{
struct node *c=(struct node*)p1;
struct node *d=(struct node*)p2;
if(c->s==d->s)
return (c->e)-(d->e);
else
return (c->s)-(d->s);
}
int main()
{
int n,i,j,max;
while(scanf("%d",&n),n)
{
max=0;
for(i=0;i<n;i++)
{
scanf("%d%d",&q[i].s,&q[i].e);
q[i].t=1;
}
qsort(q,n,sizeof(q[0]),cmp);
q[n-1].t=1;
for(i=n-2;i>=0;i--)
for(j=i+1;j<n;j++)
{
if(q[i].e<=q[j].s&&q[i].t<=q[j].t)
q[i].t=q[j].t+1;
max=q[i].t>max?q[i].t:max;
}
printf("%d\n",max);
}
return 0;
}
方法二:从前向后
code:
View Code
#include<stdio.h>
#include<stdlib.h>
struct node
{
int s;
int e;
}q[101];
int cmp(const void*p1,const void*p2)
{
struct node *c=(struct node*)p1;
struct node *d=(struct node*)p2;
if(c->e==d->e)
return c->s-d->s;
else return c->e-d->e;
}
int main()
{
int i,j,n,t;
while(scanf("%d",&n),n)
{
t=1;
for(i=0;i<n;i++)
scanf("%d%d",&q[i].s,&q[i].e);
qsort(q,n,sizeof(q[0]),cmp);
for(i=0,j=1;j<n;j++)
{
if(q[j].s>=q[i].e){
i=j;
t++;}
}
printf("%d\n",t);
}
return 0;
}

posted @ 2012-03-16 17:06  'wind  阅读(418)  评论(0编辑  收藏  举报