(HDOJ 2054)A == B ?

A == B ?


Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 

Input
each test case contains two numbers A and B.
 

Output
for each case, if A is equal to B, you should print "YES", or print "NO".
 

Sample Input
1 2

2 2 

3 3 

4 3

 

Sample Output
NO

YES 

YES 

NO

 

  AC code:

  #include <stdio.h>

#include <string.h>

void A(char *s)
{
    
int len = strlen(s);
    
char *= s + len - 1;
    
if (strchr(s, '.'))
    
while (*== '0'*p-- = 0;
    
if (*== '.'*= 0;
}

int main(void)
{
    
char *pa, *pb;
    
char a[100024], b[100024];

    
while (scanf("%s%s"&a, &b) != EOF)
    {
        pa 
= a; pb = b;
        
while (*pa == '0') pa++;
        
while (*pb == '0') pb++;
        A(pa); A(pb);
        puts(strcmp(pa, pb) 
? "NO" : "YES");
    }

    
return 0;
}
posted @ 2011-04-25 01:00  cpoint  阅读(899)  评论(0编辑  收藏  举报
浏览次数:travelocity promotion codes