(HDOJ 2099)整除的尾数

整除的尾数

Problem Description
一个整数,只知道前几位,不知道末二位,被另一个整数除尽了,那么该数的末二位该是什么呢?
 

Input
输入数据有若干组,每组数据包含二个整数a,b(0<a<10000, 10<b<100),若遇到0 0则处理结束。
 

Output
对应每组数据,将满足条件的所有尾数在一行内输出,格式见样本输出。同组数据的输出,其每个尾数之间空一格,行末没有空格。
 

Sample Input
200 40 
1992 95 
0 0
 

Sample Output
00 40 80 
15
 

 AC code:

 #include <stdio.h>

int main()
{
  
int a, b, i, c;
  
while (scanf("%d %d"&a, &b)==2 &&(a!=0||b!=0))
  {
    a 
*= 100; c = 0;
    
for (i=0; i<=99++i)
    {
     
if ((a+i)%== 0)
     {
      
if(c)
      { 
        printf(
" "); 
      }
      c 
= 1;
     printf(
"%02d", i);
    }
    }
   printf(
"\n");
  }
  
return 0;
}
posted @ 2011-04-13 22:16  cpoint  阅读(776)  评论(1编辑  收藏  举报
浏览次数:travelocity promotion codes