TFS 升级错误一则 TF400654

升级后报

[错误] TF400654: 无法配置规划工具。以下元素包含错误: BugWorkItems/BugWorkItems。TF400506: 此元素将定义表示 Bug 或缺陷的工作项的状态。每个状态必须至少存在于 BugWorkItems 中定义的一个工作项类型中。以下状态未存在于任何工作项类型中: 已建议, 活动, 已解决, 已关闭。

https://msdn.microsoft.com/library/hh913787(v=vs.110).aspx

因为提示是 BUG 项配置的原因,所以决定直接导出 BUG 项

x:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE> witadmin exportwitd /collection:http://domain.com:8080/tfs/Default /p:"ProjectName" /n:"Bug" /f:"Z:\Bug.xml"

下载后找到 States 节点

在 <STATE value="已移除" />

后增加错误所说的那四项

<STATE value="已建议" />
<STATE value="活动" />
<STATE value="已解决" />
<STATE value="已关闭" />

然后再导入

x:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE> witadmin importwitd /collection:http://domain.com:8080/tfs/Default /p:"ProjectName" /f:"Z:\Bug.xml"

 

进入 TFS 对应 Project 的 Admin 页面,点击 “配置特性”,验证后进行升级即可解决。

 

posted @ 2016-02-23 14:32 重典 阅读(...) 评论(...) 编辑 收藏