欢迎来到我的地盘:今天是

若得山花插满头,莫问奴归处!

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::
  1375 随笔 :: 0 文章 :: 722 评论 :: 23 引用

公告

术语表


Framework
:框架

feature:特性

built-in:内置的

application:应用程序

toolbox:工具栏

Server Control:服务器控件

Versioning:版本控制

Assembly程序集

Implementation:实现

Super-set:超集

multi-targeting:多目标

binding policy:绑定策略

Framework:框架

Features:特性

  

 

我曾经在博客上讨论过VS2008中将加入对JavascriptAjax智能提示(注:就是输入一个iint就直接显示出来了,你只需要拍下空格就可以了) VS2008 Javascript 调试 的支持。下面是关于ASP.NET AJAX运行时特性的一些说明,这些特性是 VS2008 .Net 3.5版本的一部分。除此以外,如果你正在使用VS2008打开一个项目,这里还有一些重要的说明。



 

.Net 3.5 中将直接包含 Asp.Net Ajax



Asp.Net Ajax 1.0
是作为一个独立于 Asp.Net 2.0 之外的下载包发布的。从.Net框架3.5版本以后,这些特性将内置在Asp.Net中,这就意味着当你在创建或者部署应用程序时,你不再需要下载、安装独立的Asp.net Ajax

 

当你使用VS2008创建一个新的定位于.Net 3.5框架的Asp.Net应用程序或者web站点时,VS将自动为你在web.config文件中添加适当的Ajax注册结点,并且在工具栏中将显示核心的Asp.Net Ajax服务器控件。

 

.Net 3.5共同发布的Asp.Net Ajax版本中将有很多不错的改进 -- 包括对于WebPartsUpdatePanel的支持、对基于WCFJSON end-points的支持、对使用Asp.Net Profile、角色的支持、对使用JavaScript进行应用程序登录的支持,并在伴随着性能提高的同时改正了许多的BUG

 


理解 Asp.Net Ajax 中的版本控制



Asp.Net Ajax 1.0
.Net 3.5 可以同时安装在一台机器上。Asp.Net Ajax 是在 1.0版本中的 System.Web.Extensions.dll 程序集中被实现的。而 包含在 .Net 3.5 中的Asp.Net Ajax 是在 3.5 版本中的 System.Web.Extensions.dll 程序集中被实现的。3.5 版本中的 System.Web.Extensions.dll 实现 1.0版本实现的一个超集,并且是与它完全兼容的(这就意味着使用时你不需要修改任何代码)

 

每一个 Asp.Net 应用程序都可以选择它所向要使用的Asp.Net Ajax 版本。这个是通过 web.config 中的 <system.web.extensions> 结点来完成的,以及其他任何 通过System.Web.Extensions.dll 程序集编译的程序(就是那些在web.config中在<assemblies>中引用或者注册的项目,还有通过项目文件引用的web应用程序)

 

你可以使用 VS2008 去创建 基于Asp.Net Ajax 3.5 的应用程序,也可以使用 VS2008 的新特性 ―― 多目标支持 ,去创建使用Asp.Net Ajax 1.0 的应用程序。我会在以后的章节中介绍如何去实现上面说的两种方式。

 


Beta 2 版本的重要信息



在几天前我们在
Web 上发布 Beta2 的时候,我们发现Asp.Net Ajax 的一个副作用。如果你读过我原创的 VS 2008 .Net 3.5 Beta 版本发布 的博客文章,你会记得我调用了这个 post-install 补丁去修正这个问题。

 

你可以下载并且运行这个补丁包,只需要花费几分种时间,并解决了我们这周早些时候在System.Web.Extensions.dll中的问题 -- System.Web.Extensions.dll这个程序集中包含了Asp.Net Ajax。如果你不运行这个补丁包,那么已经由 Asp.Net Ajax 1.0 有些东西注定是不属于你的,但是你要懂得学会去欣赏! 创建好的 Asp.Net 2.0 项目将会自动使用位于 .Net 3.5 Beta2 中的 Asp.Net Ajax 版本。这在运行起来并没有什么问题,但是,你却在无意中将.Net 3.5中的程序带到了你由 VS 2005 创建的项目中。运行这个补丁包将会改变新的 System.Web.Extensions.dll 程序集中的版本绑定策略 并且 还会确保你只能通过明确的指定 .Net 3.5 项目的方式来 使用新的 .Net 3.5 Asp.Net Ajax 版本。

 

好消息是这个负面问题被我们发现了,并且确保在同一台机器上使用 有些东西注定是不属于你的,但是你要懂得学会去欣赏! VS2008 开发 Asp.Net Ajax 不会出现任何问题。

 

这使得VS2008 在第一次打开老的Asp.Net项目时,错误的检测 Asp.Net Ajax的版本(确切地说,它使得 VS2008 认为这个项目是由 .Net 3.5 所创建的)。这需要你用VS2008第一次打开 Asp.Net Ajax 1.0 站点时多花一些额外的步骤。在 VS2008 的正式版本中,将不再需要这些步骤。

 


将ASP.NET AJAX 1.0 应用程序升级到ASP.NET AJAX  3.5


当你使用Vs2008 打开一个已经存在的使用ASP.NET AJAX 1.0 的ASP.NET 2.0 应用程序,你可以选择是否升级这个程序到 .Net 3.5(以及包含在其中的ASP.NET AJAX )

 

VS Web 工具团队最近发表了一篇 升级ASP.NET AJAX 1.0 Web站点到 .Net 框架3.5 的博客文章,这篇文章中一步步描述了如何使用 VS2008 Beta2 来实现这种升级。从ASP.NET AJAX 1.0 应用程序升级到 .Net 3.5 不需要对你的代码做任何的修改,只需要花几分钟时间等它完成。

 

Asp.Net Ajax 1.0 应用程序到 .Net 3.5还有一种情况,你可能想要升级已经在使用中的编译过的Asp.Net Ajax 控件库。Asp.Net Ajax 控件工具开发团队现在已经发布了 Asp.Net Ajax 1.0 .Net 3.5 版本的 Ajax 控件工具。你可以从这里下载

 

升级 Asp.Net Ajax 1.0 站点和应用程序 .Net 框架 3.5 详细介绍了如何使用VS2008 中的3.5版本的ASP.NET AJAX 控件工具。

 


使用 VS2008 创建 Asp.Net Ajax 1.0 应用程序(使用 多目标)


当你使用
VS2008 打开一个已有的使用 Asp.Net Ajax 1.0 Asp.Net 2.0 应用程序 ,你可以选择是否升级到 .Net 3.5 ,或者 使用新的 VS2008 的多目标特性去使用ASP.NET 2.0 ASP.NET AJAX 1.0创建应用程序。

 

VS Web 工具开发团队最近发表了一篇 使用 VS2008 创建 Asp.Net Ajax 1.0 的博客文章,详细介绍了如何使用 VS2008 Beta2 实现这样的操作。

 

在博客文章中有大量的在VS2008工具栏中使用Asp.Net Ajax 1.0 Asp.Net Ajax 服务器端控件工具的步骤。在VS2008的最终版本中,我们会发布一个Setup安装包,将自动为你实现这些步骤,同时还会在VS2008中添加Asp.Net Ajax 1.0 项目和部件模板以供使用。

 

你可能想知道 ―― 为什么要在 VS2008 中创建 Asp.Net Ajax 1.0 应用程序而不是使用有些东西注定是不属于你的,但是你要懂得学会去欣赏!?这样做的好处是:你可以在你现有的服务器上创建Asp.Net Ajax 1.0应用程序(不需要将服务器立即升级到.Net 3.5框架),同时,还可以使用VS2008 IDE的一些新的特性,比如说 JavaScript 智能提示JavaScript调试,更好的 所见即所得HTML编辑器CSS管理,改进了的代码编辑器VS专家的单元测试,使用TFS的不间断集成支持。

 


总结


.Net 3.5
现在包含了对所有ASP.NET AJAX 1.0 特性的内置支持。我会在以后写更多的博客文章来向大家讲解如何利用 .Net 3.5中提供的新特性。

 

你可以使用 VS2008 去创建 现有的、使用ASP.NET AJAX 1.0 ASP.NET 应用程序,也可以创建内置于 .Net 3.5 中的 新版本的ASP.NET AJAX。上面提到的VS Web 工具开发团队的博客文章将一步步告诉你如何实现这两种方式。

posted on 2007-08-15 14:40 莫问奴归处 阅读(...) 评论(...) 编辑 收藏
轩轩娃