uva 465 - Overflow 高精度还是浮点数?

uva 465 - Overflow

 Overflow 

Write a program that reads an expression consisting of two non-negative integer and an operator. Determine if either integer or the result of the expression is too large to be represented as a ``normal'' signed integer (type integer if you are working Pascal, type int if you are working in C).

 

Input

An unspecified number of lines. Each line will contain an integer, one of the two operators + or *, and another integer.

 

Output

For each line of input, print the input followed by 0-3 lines containing as many of these three messages as are appropriate: ``first number too big'', ``second number too big'', ``result too big''.

 

Sample Input

 

300 + 3
9999999999999999999999 + 11

 

Sample Output

 

300 + 3
9999999999999999999999 + 11
first number too big
result too big

高精度解法:直接套用刘汝佳模版

刚开始总是WA,原因有2:1.没有删除输入字符串的前导0(但是输出原字符串的时候不能删除前导0) 2.数组开太小了。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <climits>
using namespace std;

#define maxn 30000

struct bign
{
    int len, s[maxn];

    bign()
    {
        memset(s, 0, sizeof(s));
        len = 1;
    }
    
    bign(int num)
    {
        *this = num;
    }
    
    bign(const char* num) 
    {
        *this = num;
    }
    
    bign operator = (int num) 
    {
        char s[maxn];
        sprintf(s, "%d", num);
        *this = s;
        return *this;
    }
    
    bign operator = (const char* num) 
    {
        len = strlen(num);
        for (int i = 0; i < len; i++) s[i] = num[len-i-1] - '0';
        return *this;
    }
    
    string str() const 
    {
        string res = "";
        for (int i = 0; i < len; i++) res = (char)(s[i] + '0') + res;
        if (res == "") res = "0";
        return res;
    }
    
    bign operator + (const bign& b) const
    {
        bign c;
        c.len = 0;
        for (int i = 0, g = 0; g || i < max(len, b.len); i++) 
        {
            int x = g;
            if (i < len) x += s[i];
            if (i < b.len) x += b.s[i];
            c.s[c.len++] = x % 10;
            g = x / 10;
        }
        return c;
    }
    
    void clean() 
    {
        while(len > 1 && !s[len-1]) len--;
    }
    
    bign operator * (const bign& b) 
    {
        bign c; c.len = len + b.len;
        for (int i = 0; i < len; i++)
        for (int j = 0; j < b.len; j++)
        c.s[i+j] += s[i] * b.s[j];
        for (int i = 0; i < c.len-1; i++)
        {
            c.s[i+1] += c.s[i] / 10;
            c.s[i] %= 10;
        }
        c.clean();
        return c;
    }
    
    bign operator - (const bign& b) 
    {
        bign c; c.len = 0;
        for (int i = 0, g = 0; i < len; i++) 
        {
            int x = s[i] - g;
            if (i < b.len) x -= b.s[i];
            if (x >= 0) 
                g = 0;
            else 
            {
                g = 1;
                x += 10;
            }
            c.s[c.len++] = x;
        }
        c.clean();
        return c;
    }
    
    bool operator < (const bign& b) const
    {
        if (len != b.len) return len < b.len;
        for (int i = len-1; i >= 0; i--)
        if (s[i] != b.s[i]) return s[i] < b.s[i];
        return false;
    }
    
    bool operator > (const bign& b) const
    {
        return b < *this;
    }
    
    bool operator <= (const bign& b) 
    {
        return !(b > *this);
    }
    
    bool operator == (const bign& b) 
    {
        return !(b < *this) && !(*this < b);
    }
    
    bool operator != (const bign& b) 
    {
        return (b < *this) || (*this < b);
    }
    
    bign operator += (const bign& b) 
    {
        *this = *this + b;
        return *this;
    }
};

istream& operator >> (istream &in, bign& x) 
{
    string s;
    in >> s;
    x = s.c_str();
    return in;
}

ostream& operator << (ostream &out, const bign& x) 
{
    out << x.str();
    return out;
}

int main() 
{
      bign a, c, Max = INT_MAX;
      char b;
      while (cin >> a >> b >> c)
      {
        cout << a << ' ' << b << ' ' << c << endl;
        a.clean(), c.clean();
        if (a > Max)
            cout << "first number too big" << endl;
        if (c > Max)
            cout << "second number too big" << endl;
        if (b == '+')
            if (a+c > Max)
                cout << "result too big" << endl;
        if (b == '*')
            if (a*c > Max)
                cout << "result too big" << endl;
    }
}
View Code

 

更简单的解法,用浮点数瞬间秒杀。

用atof将string转为float/double.

#include <cstdio>
#include <cstdlib>
#include <climits>

char num1[300],num2[300];
int main()
{
    char  c;
    while (scanf("%s %c %s", num1, &c, num2) != EOF)
    {
        printf("%s %c %s\n", num1, c, num2);
        double a = atof(num1);
        double b = atof(num2);
        if (a > INT_MAX)                 printf("first number too big\n");
        if (b > INT_MAX)                 printf("second number too big\n");
        if (c == '+' && a+b > INT_MAX)    printf("result too big\n");
        if (c == '*' && a*b > INT_MAX)     printf("result too big\n");
    }
}
View Code

 

ps.

float的范围为-2^128 ~ +2^127,也即-3.40E+38 ~ +3.40E+38;

double的范围为-2^1024 ~ +2^1023,也即-1.79E+308 ~ +1.79E+308。

int最大值为INT_MAX(定义在<climits>),为2147483647,即0x7fffffff.

 

posted @ 2013-07-12 14:23  Norcy  阅读(987)  评论(0编辑  收藏  举报