Codeforces Round #345 (Div. 2)C. Watchmen(想法题)

传送门

Description

Watchmen are in a danger and Doctor Manhattan together with his friend Daniel Dreiberg should warn them as soon as possible. There are n watchmen on a plane, the i-th watchman is located at point (xi, yi).

They need to arrange a plan, but there are some difficulties on their way. As you know, Doctor Manhattan considers the distance between watchmen i and j to be |xi - xj| + |yi - yj|. Daniel, as an ordinary person, calculates the distance using the formula .

The success of the operation relies on the number of pairs (i, j) (1 ≤ i < j ≤ n), such that the distance between watchman i and watchmen j calculated by Doctor Manhattan is equal to the distance between them calculated by Daniel. You were asked to compute the number of such pairs.

Input

The first line of the input contains the single integer n (1 ≤ n ≤ 200 000) — the number of watchmen.

Each of the following n lines contains two integers xi and yi (|xi|, |yi| ≤ 109).

Some positions may coincide.

Output

Print the number of pairs of watchmen such that the distance between them calculated by Doctor Manhattan is equal to the distance calculated by Daniel.

Sample Input


6
0 0
0 1
0 2
-1 1
0 1
1 1

3
1 1
7 5
1 5
 

Sample Output

11

2

Note

In the first sample, the distance between watchman 1 and watchman 2 is equal to |1 - 7| + |1 - 5| = 10 for Doctor Manhattan and  for Daniel. For pairs (1, 1), (1, 5) and (7, 5), (1, 5) Doctor Manhattan and Daniel will calculate the same distances.

思路

题解:

将两个距离公式平方,可以发现,只要点x与点y中其坐标x或是坐标y的值有一个相同,则这两个点用这两个公式算出来的值就是相同的。

 

#include<bits/stdc++.h>
using namespace std;
int  main()
{
    map<int, int>x;
    map<int, int>y;
    map<pair<int,int>, int>cross;
    int n;
    long long res = 0;
    scanf("%d", &n);
    while(n--)
    {
        int xx, yy;
        scanf("%d%d", &xx, &yy);
        res += x[xx]++;
        res += y[yy]++;
        res -= cross[make_pair(xx,yy)]++;
    }
    cout << res << endl;
    return 0;
}

  

#include<bits/stdc++.h>
using namespace std;

struct Node{
	int x,y;
	bool operator < (const Node &a) const  
    {  
        if (x == a.x)	return y < a.y;
		else	return x < a.x;  
    }  
}; 

int  main()
{
    map<int, int>x;
    map<int, int>y;
    map<Node, int>cross;
    int n;
    long long res = 0;
    scanf("%d", &n);
    while(n--)
    {
        int xx, yy;
        scanf("%d%d", &xx, &yy);
        res += x[xx]++;
        res += y[yy]++;
        res -= cross[(Node){xx,yy}]++;
    }
    cout << res << endl;
    return 0;
}

  

posted @ 2017-04-30 23:58  zxzhang  阅读(326)  评论(0编辑  收藏  举报