Keywords Search

Description

n the modern time, Search engine came into the life of everybody like Google, Baidu, etc. 
Wiskey also wants to bring this feature to his image retrieval system. 
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched. 
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

Input

First line will contain one integer means how many cases will follow by. 
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000) 
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50. 
The last line is the description, and the length will be not longer than 1000000.

Output

Print how many keywords are contained in the description.

Sample Input

1
5
she
he
say
shr
her
yasherhs

Sample Output

3

HINT

自己的想法

#include<stdio.h>
#include<string.h>
int main()
{
	int m,n,flag,count,i,j,k,t;
	scanf("%d",&m);
	char a[10000],b[100][100];
	while(m--)
	{
		getchar();
		scanf("%d",&n);
		getchar();
		for(i=0;i<n;i++)
			gets(b[i]);
		gets(a);
		count=0;
		for(k=0;k<n;k++)//n个单词与字符串a进行比较
		{
			for(i=0;a[i];i++)//每一个单词都在字符串a中遍历一遍
			{
				t=i;
		     	flag=1;
		    	for(j=0;b[k][j];j++)//第j个单词在字符串a中遍历一遍
				{
					if(a[t++]!=b[k][j])
					{
						flag=0;
				    	break;
					}
				}
		    	if(flag==1)
					count++;
			}
		}
		printf("%d\n",count);
	}
	return 0;
}

//其他方法

首先对strstr函数进行介绍

包含文件:string.h

函数名: strstr

函数原型:extern char *strstr(char *str1, char *str2);

功能:从字符串str1中查找是否有符串str2,如果有,从str1中的str2位置起,返回str1的指针,如果没有,返回null。

返回值:返回该位置的指针,如找不到,返回空指针。

例子: char str[]="1234 xyz";

char* str1=strstr(str,"34");

cout<<str1<<endl;

显示:    34 xyz

#include<iostream>
#include<stdio.h>
#include<string>
#include<string.h>
using namespace std ;
int main()  
{
    int n , m ;
    while(cin >> n)
	{
        while(n--)  
		{
            cin >> m;
            getchar() ;
            char str[100][20] ;
            for(int i = 0 ; i < m ; i++)
                cin >> str[i] ;
            char s[1000] ;
            getchar() ;
            gets(s) ;
            int count = 0 ;
            for(int i = 0 ; i < m ; i++)    
			{
                char *p = NULL ;
                p = strstr(s,str[i]);//判断str[i]是否在s中找到,若没有找到p==NULL
                if(p != NULL)
                    count++ ;
            }
            cout << count << endl ;
        }
    }
    return 0 ;



 

posted @ 2014-11-23 19:38  NYNU_ACM  阅读(218)  评论(0编辑  收藏  举报