题目描述

The Fairy Ivan gave Saya three problems to solve (Problem F). After Saya finished the first problem (Problem H), here comes the second.
This is the enhanced version of Problem H.
There is a large matrix whose row and column are less than or equal to 1000000000. And there are three operations for the matrix:
1)
add: Mark an element in the matrix. The element wasn’t marked before it is marked.
2)remove: Delete an element’s mark. The element was marked before the element’s mark is deleted.
3)find: Show an element’s row and column, and return a marked element’s row and column, where the marked element’s row and column are larger than the showed element’s row and column respectively. If there are multiple solutions, return the element whose row is the smallest; and if there are still multiple solutions, return the element whose column is the smallest. If there is no solution, return -1.
Of course, Saya comes to you for help again.

输入

The input consists of several test cases.
The first line of input in each test case contains one integer N (0<N200000), which represents the number of operations.
Each of the next N lines containing an operation, as described above.
The last case is followed by a line containing one zero.

输出

For each case, print the case number (1, 2 …) first. Then, for each “find” operation, output the result. Your output format should imitate the sample output. Print a blank line after each test case.

示例输入

4
add 2 3
find 1 2
remove 2 3
find 1 2

0

示例输出

Case 1:
2 3
-1

#include <iostream>
#include <stdio.h>
#include <set>
#include <string.h>
using namespace std;


int main()
{
    int N,cases=1;
    while(cin>>N&&N!=0)
    {
        string str;
        pair<int,int> p;
        set< pair<int,int> >s;
        printf("Case %d:\n",cases++);
        while(N--)
        {
            cin>>str;
            scanf("%d%d",&p.first,&p.second);
            if(str=="add")
                s.insert(p);
            if(str=="remove")
                s.erase(p);
            if(str=="find")
            {
                set< pair<int,int> >::iterator it;
                it=s.lower_bound(p);
                for(; it!=s.end(); it++)
                {
                    if(it->first>p.first&&it->second>p.second)
                    {
                        printf("%d %d\n",it->first,it->second);
                        break;
                    }
                }
                if(it==s.end())
                   printf("-1\n");
            }
        }
        printf("\n");
    }
    return 0;
}

posted on 2015-04-28 21:09  星斗万千  阅读(160)  评论(0编辑  收藏  举报