Periodic Strings

Description

A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string "abcabcabcabc" has period 3, since it is formed by 4 repetitions of the string "abc". It also has periods 6 (two  repetitions of "abcabc") and 12 (one repetition of "abcabcabcabc").Write a program to read a character string and determine its smallest period.

Input


The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

Sample Input

1

HoHoHo

Sample Output

2

从1开始(该数同时被字符串长度取余为0),逐个尝试能否构成字符串的周期,若能,输出其最小周期,跳出循环。
#include<stdio.h>
#include<string.h>
int main()
{
    int n, count1 = 1;
    scanf("%d", &n);
    while(n--)
    {
      getchar();
      char str[83];
      scanf("%s", str);
      int length = strlen(str);
      for( int i=1; i<=length ; i++ )
      {
             if((length%i)==0)
             {
                 bool flag=true;
                 for( int j=i; j<length; j++ )
                    if(str[j] != str[j%i])
                    {
                        flag=false;  break;
                    }

                if(flag)
                  {
                    if(count1!=1)
                      printf("\n");
                    printf("%d\n", i);
                    count1++;
                    break;
                  }
             }
        }
    }
    return 0;
}