pku1088 dfs+dp记忆化搜索

滑雪
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 88861   Accepted: 33344

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子 
 1  2  3  4 5

16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

很简单的题目,一遍过,因为题目要求的是从大到小的路径,所以根本就不需要用vist标记已经访问的节点了,这条路本身就是自带有向属性
#include <iostream>
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <string>
#include <queue>
#include <stack>
#include <algorithm>

const int inf = (1<<31)-1;
const int MAXN = 1e2+10;
using namespace std;

int dp[MAXN][MAXN];
int vist[MAXN][MAXN];
int a[MAXN][MAXN];
int n,m;

int mov[4][2]={-1,0,1,0,0,1,0,-1};

int check(int x,int y){
    if(x<1||y<1||x>n||y>m)return 0;
   // if(vist[x][y]==1)return 0;
    else return 1;
}

void dfs(int x,int y){
    int nx,ny;
   // cout<<"haha"<<endl;
    for(int i=0;i<4;i++){
        nx = x+mov[i][0];
        ny = y+mov[i][1];
        if(check(nx,ny)&&a[x][y]>a[nx][ny]){
            if(dp[nx][ny]==1){
               // vist[nx][ny] = 1;
                dfs(nx,ny);
                dp[x][y] = max(dp[x][y],dp[nx][ny]+1);
                //vist[nx][ny] = 0;
            }
            else{
                dp[x][y] = max(dp[x][y],dp[nx][ny]+1);
            }
        }
    }
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF){
        int mmax = -inf;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                scanf("%d",&a[i][j]);
                dp[i][j] = 1;
                vist[i][j] = 0;
            }
        }
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                if(dp[i][j]!=1||vist[i][j]==0){
                    //if()
                    vist[i][j] = 1;
                    dfs(i,j);
                }
                mmax = max(mmax,dp[i][j]);
            }
        }
        /*for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                printf("%d ",dp[i][j]);
            }
            cout<<endl;
        }*/
        cout<<mmax<<endl;
    }
    //cout << "Hello world!" << endl;
    return 0;
}
View Code

 

posted @ 2016-04-28 00:09  iEdson  阅读(151)  评论(0编辑  收藏  举报