B - 简单带权并查集 POJ - 2492 A Bug's Life

POJ - 2492 http://poj.org/problem?id=2492

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it. 
InputThe first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.OutputThe output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!


        
 
Hint

 

Huge input,scanf is recommended.

题意是有n只虫,m对(异性),给出m对,问有没有错误的(不能出现同性)

种类并查集,画个表就知道关系转换了

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <vector>
#define Twhile() int T;scanf("%d",&T);while(T--)
#define fora(i,a,b) for(i=a;i<b;i++)
#define fors(i,a,b) for(i=a;i>b;i--)
#define fora2(i,a,b) for(i=a;i<=b;i++)
#define fors2(i,a,b) for(i=a;i>=b;i--)
#define PI acos(-1.0)
#define eps 1e-6
#define INF 0x3f3f3f3f

typedef long long LL;
typedef long long LD;
using namespace std;
const int maxn=30000+11;
int fa[maxn],ran[maxn];//0:同1:异
int n,m,flag;
void init()
{
    flag=1;
    int i;
    fora2(i,0,n)
    {
        fa[i]=i;
        ran[i]=0;
    }
}
int findx(int x)
{
    if(x==fa[x])return x;
    int fx=findx(fa[x]);
    ran[x]=ran[x]^ran[fa[x]];
    return fa[x]=fx;
}
void solve(int x,int y)
{
    int fx=findx(x),fy=findx(y);
    if(fx!=fy)
    {
        ran[fy]=!(ran[y]^ran[x]);
        fa[fy]=fx;
    }
    else
    {
        int t=ran[x]^ran[y];
        flag=t;
    }
}
int main()
{
    int t=0;
    Twhile()
    {
        scanf("%d%d",&n,&m);
        init();
        while(m--)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(flag)solve(x,y);
        }
        printf("Scenario #%d:\n",++t);
        if(flag)printf("No suspicious bugs found!\n");
        else
            printf("Suspicious bugs found!\n");
        
    }
    return 0;
}

 

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it. 

InputThe first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.OutputThe output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!


        
 

Hint

Huge input,scanf is recommended.

posted on 2018-08-06 11:25  一零七  阅读(132)  评论(0编辑  收藏  举报

导航