HDU1078记忆化搜索

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9499    Accepted Submission(s): 4007


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 
 

 

Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 
 

 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected. 
 

 

Sample Input
3 1
1 2 5
10 11 6
12 12 7
-1 -1
 

 

Sample Output
37
 

 

Source
 题意:
n*n的矩阵,从左上角开始,每次最多只能走k步,并且只能走到权值更大的点,问走过的所有的点的最大权值和是多少。
代码:
//普通的搜索会超时,记忆化搜索,当搜到某点的权值和在前面的搜索中已经算过了就直接返回。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int inf=0x7fffffff;
int f[103][103],mp[103][103];
int dir[4][2]={1,0,-1,0,0,1,0,-1};
int n,k;
int dfs(int x,int y)
{
    if(!f[x][y]){
        int tmp=0;
        for(int j=1;j<=k;j++){
            for(int i=0;i<4;i++){
                int xx=x+dir[i][0]*j,yy=y+dir[i][1]*j;
                if(xx<0||xx>=n||yy<0||yy>=n) continue;
                if(mp[xx][yy]<=mp[x][y]) continue;
                tmp=max(tmp,dfs(xx,yy));
            }
        }
        f[x][y]=tmp+mp[x][y];
    }
    return f[x][y];
}
int main()
{
    while(scanf("%d%d",&n,&k)){
        if(n==-1&&k==-1) break;
        for(int i=0;i<n;i++){
            for(int j=0;j<n;j++){
                scanf("%d",&mp[i][j]);
            }
        }
        memset(f,0,sizeof(f));
        int ans=dfs(0,0); 
        printf("%d\n",ans);
    }
    return 0;
}

 

posted @ 2017-03-14 20:15  luckilzy  阅读(301)  评论(0编辑  收藏  举报