关于appcompat v7出现的问题

一、问题描述:

   新建了一个MIN-SDK为API 8的工程之后,TARGET-SDK为API 17的Android工程之后,自动生成的appcompat v7会提示“v7/value21:no resource ....(blabla)”,

二、解决:

method 1.新建一个MIN-SDK为4.0以上的工程,这样就不需要使用这个兼容的包

method 2.不更改MIN-SDK,而是更改TARGET SDK为API 21以上的版本

参考资料:

http://stackoverflow.com/questions/26453942/error-at-lib-support-appcompat-v7

http://www.cnblogs.com/peach/p/4112207.html

posted @ 2015-06-14 11:48  小小鑫  阅读(214)  评论(0编辑  收藏  举报